Sharing does not take the right text or picture

With the premium plugin, you can define which image and text should show when people share your page(s). You can either set a global sharing image & text (under question 6 in the plugin), or define it individually per post or page. For the latter, please insert this information on the edit post/page-page (i.e. on the page where you write your post, at the bottom you will see a new section where you can define the sharing image and text).

If you did that, but sharing still does not take the image or text you defined:

  • If you have a cache plugin installed please, disable it temporarily
  • Note that the social media platforms (e.g. Facebook) first need to scrape the new sharing information from your website. They do this in regular intervals, but it is not immediate. If you want to speed things up for selected posts/pages, please enter the url of the page you want to share on and click on “Fetch new scrape information”. That will make Facebook scrape your site again, and you will see the updated information which image or text gets shared.

    Linkedin is especially slow in updating the information – it caches the shared data for 7 days. To remove the cache, add a random string after url, e.g. if your url is then enter and click on enter in your browser. Then Linkedin will regard it as a new url and scrape the information.

If those points did not work, please raise a support ticket (at the top of the plugin’s settings page).

Updating of plugin does not work

If you try to update the plugin and get the error message…

“An error occurred while updating USM Premium: Could not create directory. Ultimate-Premium-Plugin/css/images”

…then the reason is most likely a permission issue on your server. Please give 755 permission to the plugin folder (or ask your server team / hosting company to do so).

I have other issues (after plugin has been activated)

Please have a look at our General FAQ

Share by Email